400 Server Error/Network Error

I am unable to search for anyone using the rocket league tracker. I only receive the errors mentioned in the topic name.

Works fine for friends when they go to my tracker but when I do it I only receive

I tried using a vpn to no avail and it’s the same with edge, chrome and firefox

Hi @cyberdigi and welcome to the TRN forums.

The error you’re receiving is what is known as a “client side” error, meaning the request you sent was malformed for some reason, and the TRN server could not process it.

I was able to look at your profile on RL without issues, so there is indeed something going on with your browser or computer that is causing these requests to error out.

Can you try clearing your cookies for the browser you’re using and try again? Here are the relevant guides for clearing cookies for the major browsers:

Clearing the cache did nothing for me sadly. Not on any of my installed browsers.

If it helps this has been an issue for at the very least a week but before that there was a long period where I didn’t use the tracker at all. Now I can’t check how long ago it last was as I cleared the history as well :stuck_out_tongue:

Are you logged in on the TRN website (it’s not a requisite to view profiles, but it could be something in your session is causing the query to malform)? If so, can you try logging out and logging back in first before looking up yours (or another person’s) profile?

Also, do you find that the issue persists on Incognito/Private tabs?

I hadn’t made a TRN account before today and it does not change whether I’m logged in or not. It’s also the same in private/incognito tabs.

At this point I’m grasping for straws so I tried changing my ipv4 and restarting my router but none of those worked either, also disabled adblockers and malwarebytes browser protection but nope. I tried with my phone which works fine, it even works when I’m connected over the same wifi as my pc so it would seem the website hates this pc in particular.

I genuinely have no idea what is causing this and I’ve troubleshooted for longer than anyone ever should for a simple webpage so I’m giving up for now. If you have any other good ideas feel free to post em but no worries otherwise.

One thing that can cause these errors is a bad local DNS cache of the site you’re trying to hit. Usually this will resolve itself over time once your local DNS cache is updated through normal browsing, but it could be a stale/corrupted record that is causing some sort of issue.

You can try clearing your DNS cache to see if that will work. Here are the methods of clearing DNS cache for the different OS types: