【help】return 403 on browser,return 1020 on postman

when I try to request on browser, by click the “try it out” button on the documentation page, it always returns error code 403.
when I try to request on postman, it always returns error code 1020
please help to find out what problem is, thanks!

Hello @kumoo_dev and welcome to the TRN forums.

Can you please provide what sample data is being provided in the request? I’m not seeing the same issue when attempting to reproduce what you’re experiencing.

My request (made from clicking the “Try it out” button on the documentation page)

GET https://public-api.tracker.gg/v2/apex/standard/profile/psn/Daltoosh
TRN-Api-Key: <redacted>
Accept: application/json
Accept-Encoding: gzip


  "data": {
    "platformInfo": {
      "platformSlug": "psn",
      "platformUserId": "Daltoosh",
      "platformUserHandle": "Daltoosh",
      "platformUserIdentifier": "Daltoosh",
      "avatarUrl": "https://avatars.trackercdn.com/api/avatar/2/Daltoosh.png",
      "additionalParameters": null
    "userInfo": {
      "userId": 2172504,
      "isPremium": false,
      "isVerified": false,
      "isInfluencer": false,
      "isPartner": false,
      "countryCode": "US",
      "customAvatarUrl": null,
      "customHeroUrl": null,
      "socialAccounts": [

(response clipped here for brevity)

EDIT: It’s worth mentioning that both HTTP 403 and CloudFlare’s error 1020 are authentication related errors (Forbidden/Access Denied), meaning you likely don’t have the “TRN-Api-Key” set or have been IP blocked due to seemingly malicious activity.

I am sure that I has set “TRN-Api-Key” in headers, and use the same url as your answer (Which is copied from documentation page).
I got this error from the first time I made the request, so I guess the occurrence of this error on my case should have nothing to do with the request frequency.
But thanks for your reminder, I found there is a prompt on MyAppDashbord page, like “Your application for production use has been received and is awaiting review.”
Is that means my app_key is not avalible now? (Or can I show you my app_key to confirm it ?)

Thank you for your attention!


Hi @kumoo_dev,

Could you clarify please if the issue still persists? Have you tried to send requests from a different IP or have you tried to create a new app to get a new API key?

My problem was solved by changing the network proxy.
Thanks again for your attention and suggestions!