Trying to link profile through app yields blank screen

I m on android oreo (8.1) using a oneplus 2 phone. Every time i try to link my rocket tracker profile using the in-app buttons, i end up looking at a white screen pop-up for minutes.
I should note that i am using a rooted version of the lineage os, however everything else works perfectly fine.
Is my account blocked accidentally maybe? Or is this feature not yet available to anyone due to the early development stage?
Other than the linking thing, app works fine. I can search and look at everyone’s progress much smoother than the old version.
The main reason i want to link my profile, other than ease of access, is to enable push notifications on a couple of people i play with so as to track their progress. Any help is appreciated.

Hi @kleisthenis_gr,

Do I get it right that you are trying to link your profile using “Link Profile” on the home page? Are you currently signed in (if not, you will see “Sign In or Register” when you tap “More” at the bottom navigation)?

These are the exact buttons i tried, as shown in your picture.
When trying the “more” option you mentioned, i don’t get a blank screen. However after the loading circle appears, nothing happens and remain signed out.
I have already tried reinstalling the app, evan tried a vpn in case my ip was causing the problem.
Is it just me? Any ideas on what the issue could be?

I don’t know if you find this info useful but every time i try to link my profile, it tries to open the following link ony Firefox browser

I would really appreciate any suggestions to hopefully gain full functionality of the app. @LostBlood

Hi @kleisthenis_gr

If I understand correctly, the “more” does not give a black screen. Do the loading circles keep loading or do they disappear as shown in the video below?

Have you tried clearing app cache and app data?
If that isn’t working can you try Installing another browser and setting it as your default browser app.

Precisely as in your gif, however the “sign in or register” button does not change after loading.
I cleared app cache, installed chrome, set it as default, restarted device. The only progress made was that the web page actually opened this time instead of the usual white screen. However after correctly filling my credentials, i remain signed out when it returns me to the app.
At this point i m considering reflashing the official firmware if you believe it might be a factor.
Thanks for your time so far.