Fortnite - Mythic Rewards Bugged

Hey All,

Love the idea of getting rewards for Mythic or however you get them.
First time I saw them was today.
It was def bugged though.
Clicked on the reward.
It said swipe to see what I got.
Tried to swipe but it didn’t work.
I did get the “something is bugged” message.

Just letting you all know.
Can’t wait until they work!

  • Mountain

@Mountaintop488 I’ve dropped your issue into our internal groups for review; I am just writing up this quick message so you know we’re aware :slight_smile:


1 Like

No worries at all!
I know this is a new feature and the feedback will help.
I love the idea of rewards!

hey @Mountaintop488 hope you’re doing well. Was the reward pack consumed (removed from your inventory) after you tried to open it and got the error?

Hey @Loch I’m doing great dude. Hope you are too!

Yes, after this happened it said, and still says “No rewards”
If I click View Unclaimed, three grey blank boxes appear and then disappear immediately.
Then it changes to View Claimed and nothing happens when I click it.

Hope this helps!

Thanks. I gave you another pack, should work now (we hope!)

1 Like

Got it!

Thank you so much!
I love this feature. It worked great this time.
Gives everyone something to look forward to after the division rankings. Very cool.

Thanks again @Loch !

1 Like